[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: TSVN does not support NTLM authentication

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: 2007-12-13 20:09:15 CET

Adrian Wilkins wrote:

>> Almost correct: it's available in Subversion built from trunk (the
>> upcoming 1.5), but *not* in 1.4.x - that part has not been backported
>> (and there's a veto vote which prevents it from ever being backported).
>>
> D'oh. 1.4 doesn't even have libsvn_ra_neon where it's processed. My bad
> for thinking that lower revision == support. Guess I'm just thinking too
> three-dimensionally :-)

Not quite correct: 1.4 *only* has libsvn_ra_neon. TSVN was not linked
against libsvn_ra_serf in the 1.4.x releases.
But the feature that you can configure the auth mechanisms is only
available in the 1.5 nightly builds.

> I'll have a look at any possible 1.4 / 1.5 WC incompatibility ; if it's
> the same deal as 1.3 => 1.4 (e.g. highly incompatible) I shall have a
> go, but I'll be restricting myself to the command-line client ; it's
> just too easy to touch a WC with TSVN and accidentally have it "upgraded".

The working copy format has changed. Which means once you do something
with a TSVN nightly build on your working copy, you can't use that
working copy anymore with older clients.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Thu Dec 13 20:09:31 2007

This is an archived mail posted to the TortoiseSVN Dev mailing list.