[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: bug report:encoding bug in revision graph

From: Stefan Kng <tortoisesvn_at_gmail.com>
Date: 2005-12-15 19:17:21 CET

wrote:
> recurrence of the bug
> =======================
> *run svn1.2.3 as an apache module at windows2000 server ,(perhaps
> this is not important).
> *install the nightly build:TortoiseSVN 1.3.0, Build 5153
> *add a file with chinese character,eg ".txt,to repository
> *tag or branch this file
> *see the revision graph of the file
> *right click a revision node
> *click "show log" at popup menu
> *error message box "REPORT request failed
> on...'/svn/test!svn/bc/51/trunk/src/%E5%A7%B9%3Ftxt'path not found" shows.
> *%E5%A7%B9%3F is the wrong encoding,the correct is %E6%B1%89(in
> utf-8 encoding)
>
>
> locate the bug
> ===============
> if you right click a file,"TortoiseSVN"-"show log" ,bu not run "show
> log " from "revision graph", you can not see this bug.
> so this bug belongs to "revision graph" at RevisionGraphDlg.cpp
>
> in previous version
> ======================
> this bug lives in TortoiseSVN-1.2.6 Build 4786 too,if you compare two
> revision nodes in revision graph,you can see similar bug
> ".....not-existence...."

Should be fixed in revision 5164.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.tigris.org
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Thu Dec 15 19:17:58 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.