[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [TSVN] Select Revision don't work with date/time (v.1.2.2)

From: Simon Large <simon_at_skirridsystems.co.uk>
Date: 2005-09-20 12:12:27 CEST

René Vestergaard wrote:
> The "Select Revision" function of the "HEAD" button in
> the Repository Browser don't work when entering date/time.
> For instance after clicking the "HEAD" button and choosing
> a revision by date/time an "Invalid revision number" error arise.
> The examples from the tooltip-error-message don't work either.
>
>
> Setup information:
> ------------------
>
> * Client computer:
> We have installed TortoiseSVN-1.2.2.4295-svn-1.2.3.msi on
> a PC with Windows XP SP2 DK (DK = danish).
> We have tried to enter both US and DK date-format, but it don't work.
> When we use the commandline SVNtools (in stead of the Tortoise GUI)
> it works fine.
> Here is an example of commandline that works:
> svn co --revision {2005-09-14} svn://ps-04/FastDB
>
> * Server computer:
> The server is running svn-win32-1.2.3.zip.

I can confirm this problem exists in r4306. Seems to set the revision to
-1 (displayed as an unsigned number on the button?).

Also, the tooltip only appears if you type an invalid date format. Is
that intentional?

Also also, pressing F1 from this dialog doesn't work ("Failed to launch
help"). Is there an ident missing from the help file?

Simon

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.tigris.org
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Tue Sep 20 12:12:30 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.