[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [TSVN] Installer defaults to "program files"

From: Peter Mounce <pete_at_molehole.org>
Date: 2005-08-15 11:39:06 CEST

SteveKing wrote:
> On 8/15/05, Peter Mounce <pete@molehole.org> wrote:
>
>
>>When installing:
>>* if it's a clean install, the package looks for [ProgramFilesFolder],
>>which is, I believe, localized since it comes from the system. It
>>stores whatever path is chosen in the registry.
>
>
> I don't think that's true. Check "StructureFragment.wxs", there's a
> hardcoded "Program Files" in the directory name. Other than that: I
> really get "program files" on my OS, even though previously I always
> got "Programme" - and other programs use the correct "Programme" too.
>
> (feels strange: I'm the one reporting bugs for a change ;) )

My world is on its head. ;)

This is probably best fixed by you and Luebbe (would someone _please_
tell me the alt+3-digit-number I need to type a u-umlaut...) with the
WiX localisation facilities...? See the tutorial at
http://wix.sourceforge.net/tutorial . If we're going to do any sort of
localization in our setups, we should probably do it like that...

Pete

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Mon Aug 15 11:39:21 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.