[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[TSVN] Starting RepoBrowser using TortoiseProc and svn: link

From: Kirk Lapray <kirk.lapray_at_gmail.com>
Date: 2005-08-08 22:24:46 CEST

When I click on a link that starts with svn: the RepoBrowser URL
dialog opens, but it is blank. After looking into this more it looks
like when TortoiseProc is called to start a checkout the corresponding
tsvn: is remove from the beginning of the URL, but when starting the
RepoBrowser svn: is not remove from the beginning of the URL. This
makes it impossible to start the RepoBrowser and have it point to a
http: URL. Since svn: is also a protocol I can see why it isn't
automatically removed, but it would be nice if there was a solution so
that it could be used with http: repositories. Either a different
prefix could be used instead of svn:, or people that needed to access
a svn: repository could just use svn:svn:// to access it.

I hope this makes sense. I am trying to make starting the RepoBrowser
at the correct location easier for users, but currently I am only
getting the RepoBrowser URL screen without any URL. I would really
like to have this RepoBrowser started at the correct URL.

If I am overlooking something, or if there is another way to do this
please let me know, otherwise I would really like to see this ability
added.

Thanks,

Kirk

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Mon Aug 8 22:25:27 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.