[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[TSVN] File Locking - Bug?

From: <fe-listas_at_bol.com.br>
Date: 2005-07-18 19:05:47 CEST

Hi,

I'm using SVN 1.2.1 and TSVN 1.2.1 (in fact I always use the latest TSVN
build).

Sometimes I have to lock several files in the repository to work on them,
and often I get the following situation.

I select some files and request to lock them (the locking window pops up).
I enter *no* comments, and confirm the operation. The LogDialog pops up
and shows me each file being locked. But then, sometimes, the process
simply stops. The LogDialog is still open, but nothing happens. After
waiting a long time, I press the cancel button and nothing happens. I
then kill the window. When I look at the repository, some files are
locked and some are not. And the file on wich the process stoped is
marked as *not* being locked, but on SVN it is. First I thought it was a
communication error between SVN and TSVN.

Next I go to the CheckModifications window, and break the lock of the file
where the process stoped, so I may lock it again with TSVN (cause TSVN
doesn't knows it is locked). I then select only that file and try to lock
it again with TSVN, but the same problem happens. The LogDialog window
pops up, but nothing happens. After a time I cancel/kill it. I got to my
Linux box and used the 'svn' tool to try to lock the file manually, and
it worked. Then I tried TSVN again, and it didn't. Then I tried something
else. Remeber that I was not adding any comment while locking the files.
This time I added a comment while trying to lock that file. And it
worked! So I began to always add a comment while locking multiple files,
but then the problem happened again. I took the file where the process
stoped, and tried to lock it separately with the same comment I tried to
lock all other files together before, and it didn't work. Then I tried to
lock it with a different comment, and then It worked again.

I really don't understand what's happening. I thought it was a SVN
problem, but when I used the 'svn' tool and locked the file successfully
with the same comment, I came to think it could maybe be a problem in
TSVN.

Resume: Sometimes, while locking a file, nothing happens. When I change
the comment to lock the file, it works. This happens only on TSVN, with
the 'svn' tool from SVN it works always.

Thanks,

-----------------------
Björn Martins Paz

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Mon Jul 18 19:06:04 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.