[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [TSVN] Icon overlays still not correct

From: Simon Large <simon_at_skirridsystems.co.uk>
Date: 2005-07-14 00:56:53 CEST

Norbert Unterberg wrote:
> 2005/7/12, SteveKing <steveking@gmx.ch>:
>
>
>>The way it works now is that if a subfolder discovers a status change,
>>it tells that to its parent and that one changes the recursive status
>>accordingly.
>
>
> Obviously, this does not work either on my machine. Maybe we have a
> race condition here, at least on multi-cpu or hyperthreaded systems?
> Explorer refreshes take place at the same time as the cache crawls for
> a new status?

I don't know if this helps at all, but I found a non-updating overlay
status in my TSVN trunk WC. Steps to reproduce:

Open a single fresh explorer window and navigate so that left pane shows
the top level trunk structure:

TortoiseSVN (this is my trunk folder)
   +bin
   +contrib
   +doc
   +ext
etc

Right pane shows contents of doc folder.

Double click on CreatePot.bat

When the pot creation is finished, the po folder in the right pane
doesn't get modified. Waiting a while and pressing F5 does not help.

Once you open the po folder, then it gets it of course.

This is on Win2K, single (old) CPU, no hyperthreading, nothing clever
going on.

Simon

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.tigris.org
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: dev-help@tortoisesvn.tigris.org
Received on Thu Jul 14 00:56:10 2005

This is an archived mail posted to the TortoiseSVN Dev mailing list.