[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [TSVN] TBlame

From: Stefan Küng <stefan.kueng_at_wagner-group.ch>
Date: 2004-09-06 10:59:14 CEST

Lübbe Onken wrote:

> Russel Hind wrote:
>
>>I like the new Blame app (tried it from last nights nightlies).
>
> So do I :-)

Can you provide an app icon for it? Right now, the icon for
TortoiseBlame is lame.

> Blame doesn't work for files that didn't exist in "From Revision". If you
> try to annotate TortoiseSVN\doc\source\de\tsvn_ch04.xml from revision 1 to
> now. Blame will crank away for a while and return with an empty error
> message. If I annotate from revision 1000 to now, everything works fine.
> I don't know if TSVN can do anything about this problem.

That's not because the file didn't exist in revision 1, but because in
the beginning of the file it was in UNICODE which Subversion treats as
binary. And binary files can't be "blamed". Later then, I converted the
file from UNICODE to UTF8, which _can_ be diffed and blamed in Subversion.

> Tiny problem: In the "Blame Progress dialog", it looks like the german
> message string "this will take a while..." is being wrapped and partly
> overwritten by the status messages "fetching..."

Can't do much about that. The progress dialog can't really be resized by
the program using it. So you should consider using another translation
for that string.

Stefan

Received on Sat Sep 11 20:13:50 2004

This is an archived mail posted to the TortoiseSVN Dev mailing list.