[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] Latest Subclipse (1.10.13) Unreliable

From: Jamie Jackson <jamiejaxon_at_gmail.com>
Date: Thu, 8 Sep 2016 10:25:52 -0400

I've been using Subclipse for probably over a decade now, but the
version(s) from the 1.12 updater site have been driving me crazy.

I'm getting:

   1. Hung merges
   2. An issue with failed switches blocking any other SVN operations from
   running <http://subclipse.tigris.org/issues/show_bug.cgi?id=1654>
   3. Queued SVN operations causing hangs (say I revert then switch without
   waiting for the revert to complete)
   4. Tree conflicts that a revert won't fix. Subclipse-invoked cleanups
   don't help. I have to go to TortoiseSVN to revert.
   5. Long delays in the project reflecting the new URL (in Project
   Explorer) after a switch (actually, that last issue goes as far back as I
   can remember, though an svn update post-switch seems to refresh it).

The first few issues require an Eclipse restart (or often, I have to kill
the Eclipse process from Task Manager). I have to restart (or kill) Eclipse
several times an hour.

Sometimes I'm forced to give up and use TortoiseSVN, but for most things, I
prefer Subclipse (when it's working well).

Are others having these problems, too? If so, have you, say, downgraded
your Subclipse? Have you switched to another Eclipse SVN client?



To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2016-09-08 16:26:04 CEST

This is an archived mail posted to the Subclipse Users mailing list.