[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Reg: "svn: This client is too old to work with working copy" issue [RAD 6.0/Subclipse 1.0.6/TortoiseSVN

From: Mark Phippard <mphippard_at_collab.net>
Date: Wed, 24 Dec 2008 09:53:55 -0500

Subclipse 1.0.x contains support for Subversion 1.4. So your only
real solution is to use TortoiseSVN 1.4.x as well so that you are not
mixing clients.

You will not be able to simply copy the JavaHL DLL's into Subclipse
because the change from 1.4 to 1.5 was too dramatic. The DLL has
changed into many DLL's and Subclipse will not know about those other
ones or how to find them. Also the JavaHL Java library used by
Subclipse will not match with the DLL's.

Your other option is to just be careful about mixing clients. You can
use TortoiseSVN 1.5, but stay away from the working copies that you
are using in Subclipse. As soon as TortoiseSVN touches one of these
it will be upgraded and unusable.

Mark

On Tue, Dec 23, 2008 at 5:38 PM, Subbu Vundamati <soobboo_at_gmail.com> wrote:
> Hello All,
> I am trying to use Subclipse 1.0.6 on Rational Application Developer 6.0
> (based on Eclipse 3.0) along with TortoiseSVN version 1.5.1, Build 13563 -
> 32 Bit. Whenever I use TortoiseSVN for Lock/Unlock or any other operation
> on a project then try to use Subclipse for any Subversion operation on the
> same project, I am getting the message "svn: This client is too old to work
> with working copy" (reason being obvious).
> I tried following the instructions on the thread below to see how it goes:
> http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=791132
> I did get all DLL files from Subversion bin folder and placed in win32
> folder of Subclipse plugin (within RAD6 eclipse/plugins folder) but it did
> not help; I kept getting this error. By the way, I did use latest DLLs from
> the appropriate Subversion release (1.5.1).
>
> Should the instructions from Mark on the above thread apply to this case
> (with these particular software - RAD 6.0 and Subclipse 1.0.6 - combination)
> as well?
> I believe 1.0.6 is the last version that is compatible with Eclipse 3.0,
> please correct me if I am wrong.
>
> I hope I am not missing something too obvious (I am sure this statement
> would not automatically become a genuine excuse).
> I would like to know if anybody else is using RAD6/Subclipse/TortoiseSVN and
> got this issue resolved.
> Any suggestions will be tried and appreciated. Please let me know if you
> need more information or need to see any log files.
> Thanks for your help.
> Subbu.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1047&dsMessageId=991637
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subclipse.tigris.org].
Received on 2008-12-24 15:54:04 CET

This is an archived mail posted to the Subclipse Users mailing list.