[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] svnant and authentication

From: Mark Phippard <markphip_at_gmail.com>
Date: Mon, 30 Jun 2008 14:35:35 -0400

On Mon, Jun 30, 2008 at 2:31 PM, Peter Kahn <citizenkahn_at_gmail.com> wrote:
> Mark, does svnant work with svn+ssh and private/public key pairs? My
> current auth solution isn't working reliably. sometimes it fails and on a
> rebuild auth works. I am looking for a more reliable solution, so I fgured
> I'd try the ssh key option. I have it working from the commandline, but not
> from svnant. So, is this a known issue or should it work? I'm setting the
> env var SVN_SSH thusly:
> SVN_SSH="ssh -i `pwd`/../config/svn_dsa"
>
> On the commandline the following works
> svn ls svn+ssh://builder@svn/myrepos
>
> but when I execute this from svnant it fails. Any idea as to what I should
> be looking at?

I've never used svnAnt, and based on the lack of responses I see on
this list, I'd say no one is maintaining it either. I am getting
close to booting it from the repository as it reflects poorly on
Subclipse that people think the two are related.

A problem I could see with SSH and Ant, is that SSH often requires
some form of interactivity. If your SSH client was configured so that
it could just connect and work with no interaction, I'd expect it to
work. Of course the Ant script would have to run as the right user
with the right HOME folder etc.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-06-30 20:35:41 CEST

This is an archived mail posted to the Subclipse Users mailing list.