[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] Subclipse doesn't hide .svn/ in current Subclipse 1.3 snapshot?

From: Mark Phippard <markphip_at_gmail.com>
Date: Mon, 5 May 2008 11:20:05 -0400

On Mon, May 5, 2008 at 10:59 AM, Jens Seidel <jensseidel_at_users.sf.net> wrote:

> I currently test Subclipse 1.3 and have a few questions:
>
> The plugins
> Win32 JavaHL Binaries
> Subversion JavaHL
> are (among others) installed on my Linux system. I wonder why, do I need
> these?

The Win32 plugin should not be installed. I will review the settings
so that Eclipse filters it out.

> Is "Subversion JavaHL" supposed to contain the JavaHL library or
> only the "glue" to allow Java to access libsvnjavahl-1.so?

We cannot provide JavaHL for any platform but Windows -- because there
is no way to deliver the dependencies. You can install the CollabNet
Subversion RPM and install Subclipse from this same site and then we
will use the JavaHL from that RPM.

http://merge-tracking.open.collab.net

Also see this post to this mailing list:

http://subclipse.tigris.org/servlets/ReadMsg?list=users&msgNo=11651

> Where is SVNKit? Is it no longer supported? This would be a pitty,
> especially as the latest stable Subclipse version 1.2.4 ships with a
> slightly outdated SVNKit package which doesn't work with Subversion 1.5.

SVNKit has been on our update site since we posted the version for SVN
RC4. It was also mentioned in the release announcement post to this
mailing list:

http://subclipse.tigris.org/servlets/ReadMsg?list=users&msgNo=11641

> I observered also the following minor error:
> Trying to open a ressource (via Ctrl+Shift+R) displays also .svn-base
> files from .svn/prop-base/ directories. I assume this should be ignored
> by Subclipse or is a workspace setting responsible?

I do not see this happen. Subclipse does not specifically filter
these out. What Subclipse does, when a project is associated with
Subclipse, is mark those resources as "Team Private" and then Eclipse
UI is responsible for filtering them out. It would seem that these
resources are nor marked for you. You could try a Close Project/Open
Project cycle.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-05-05 17:20:17 CEST

This is an archived mail posted to the Subclipse Users mailing list.