[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] Slowness when switching or branching

From: Tom Walter <walter.tom_at_gmail.com>
Date: Fri, 02 May 2008 10:50:44 +1000

I've noticed recently that switching branches has gotten quite slow via
subclipse. It didn't used to be so bad but has started to be noticable
in the last few months. I'm not sure if it started after a particular
Subclipse update or not.

I'm not sure what is going on because the actual svn side of the
equation seems to happen quite fast according to the svn console. But
after the console reports 'Updated to revision X', the svn switch task
sits there seemingly doing nothing at something like 15% for up to
several minutes before completing. And only then do the 'Updating
changesets for SVN subscriber' tasks start running.

It's a little frustrating since the SVN switch task seems to block
saving and other user tasks until it's complete (even on files unrelated
to the switch).

Any idea what's going on? I am running Eclipse 3.3.2 in Windows XP, with
Subclipse 1.2.4, the and the SVN server is 1.4.2.

My project is quite large (4000+ files)

Cheers
Tom

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: users-help_at_subclipse.tigris.org
Received on 2008-05-02 02:51:18 CEST

This is an archived mail posted to the Subclipse Users mailing list.