[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] No Team > Share Project.. after switch from Subversive

From: S Page <skierpage_at_earthlink.net>
Date: 2007-11-30 06:13:48 CET

Mark Phippard wrote:
> On Nov 29, 2007 9:27 PM, S Page <skierpage@earthlink.net> wrote:
>> [Problem after switching]
>
> Did you disconnect the projects before you uninstalled Subversive?

No, I didn't know about Disconnect. To clarify, I never uninstalled
Subversive; I renamed my old eclipse 3.1 and installed a brand new
C:\Program Files\eclipse 3.3, in which I only installed Subclipse.

> Eclipse registers the project with a team provider. It has no way to
> know that Subclipse and Subversive both deal with Subversion. Team >
> Share will not be available if Eclipse thinks it is already connected.

Ahh, OK. And I guess because Subversive wasn't around in my new
eclipse, there was no provider to supply Team > Disconnect... and the
other Team actions.

For another SVN project, from its context menu I chose Close Project and
then Open Project. That was enough to fill the Team submenu and make
the Subclipse SVN decorations appear! So that might be another fix for
this problem besides Mr. Samet's rename-refresh-rename-refresh and your
solution.

> You might need to reinstall Subversive do that you can disconnect.

Or maybe I could view the projects in my old eclipse + Subversive and
Team Disconnect them there.

Anyway, I've got past this with your help. Thanks!

--
=S
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: users-help@subclipse.tigris.org
Received on Fri Nov 30 06:13:55 2007

This is an archived mail posted to the Subclipse Users mailing list.