[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] Subclibse JavaHL (JNI) not working

From: AS Maps <andreas.schoeneck_at_gmail.com>
Date: 2007-11-03 18:04:44 CET

Hello!

Subclipse does not work within the latest Eclipse 3.4 x86_64 release
(3.4M3) in JavaHL (JNI) mode. This seems to be caused by missing x64
libraries. Sublise only ships with Win32 compatible ones that can not be
loaded from a x64 JavaVM.

Unfortunately the PureJava-mode is not applicable to the used svn
environment - it simply does not work with SVNKit and I don't have an
option to change this, so I have to use PageAnt for private-key
authentification. I already tried to get apprpriate libraries from
elsewehre (OpenSLL x64, libraries from TortoiseSVN x64) but they are not
recognized at all.

-----
So I need precompiled x64 binaries to get JavaHL to work with my
repository. Is it possible to build a package (like the Win32-jar that
already ships with Subclipse) that can be downloaded? It would be nice
if. BTW: x64-TortoiseSVN works well (even with x86-PageAnt auth.)
-----

Steps to reproduce: Download latest x86_64 Eclipse, install Subclipse,
choose JavaHL. This will result in an error message telling that some
libraries cannot be found.

-----
OS: Windows Vista Business 64-Bit
Eclipse: Eclipse SDK
                Version: 3.4.0
                Build id: I20071101-2000
Subclipse: 1.2.4
ClientAdapter: tried JavaHL, tried SVNKit
Used protocol: svn+ssh
-----

Thanks in advance.
Regards, Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: users-help@subclipse.tigris.org
Received on Sat Nov 3 18:43:05 2007

This is an archived mail posted to the Subclipse Users mailing list.