[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-users] 100% CPU in Eclipse - seems due to Subclipse with overlapping projects

From: Mark Phippard <markphip_at_gmail.com>
Date: 2007-06-25 18:03:30 CEST

On 6/24/07, Alan Kent <ALAN.J.KENT@saic.com> wrote:
> I am experiencing Eclipse 3.2.2 going to 100% CPU with Subclipse 1.2.2.
> This is under Windows XP. Task Manager shows lots of system time going
> on (say 70% red 30% in the 'performance' tab). Progress monitor often
> reported SVNStatusSubscriber running very slowly. I tried both JavaHL
> and SVNKit - both fail in same way. I have bumped up memory for Eclipse
> (some people were getting 100% CPU due to lack of memory). I don't
> think its memory limit related.

Alan, I am going to take a new look at this issue and the patches from
last year. However, when I started, and tried to recreate the
problem, I found that using Eclipse 3.3 RC4 the problem seems to be
almost completely gone. Is there any chance you can try this and see
if you see the same as me?

There are still some issues that could be addressed, but it looks like
Eclipse has possibly resolved the hanging problems.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: users-help@subclipse.tigris.org
Received on Mon Jun 25 18:03:10 2007

This is an archived mail posted to the Subclipse Users mailing list.