[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] Subclipse update on windows causes system pauses

From: Zach Bailey <zach.bailey_at_hannonhill.com>
Date: 2007-06-20 23:43:06 CEST

Hi,

I realize this may be more suitable for a JavaHL mailing list if there
is one, however I believe it may have to do with Subclipse to an extent
as well.

Here is the problem I am running into: when I do an "update", my
computer sometimes completely becomes non-interactive for a noticeable
amount of time, generally anywhere from 1-5 seconds. My assumption is
this is when Subclipse is interacting with the native Subversion API
libraries supplied on the Windows platform. Note that this is not just
Eclipse that seems to be taking a hiatus but it infact interferes with
the entire O/S (i.e. other programs I am trying to use become
unresponsive as well).

My question is, why does this happen? Is this due to some issue when
interfacing between Java and native libraries using JNI? I must admit it
is really annoying to have my computer "freeze" for a couple seconds
every time I do an update (which is multiple times daily).

I know the simple solution is to use JavaSVN/SVNKit, but is this
something that is being looked into or that the developers are aware of?

This happens on both my work and home systems:

System specs
Intel Core Duo/Quad processors
Windows XP
Latest Subclipse using JavaHL
Both Eclipse 3.2 and 3.3RC4 exhibit the behavior

Could anyone provide any insight?

Thanks,
-Zach

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: users-help@subclipse.tigris.org
Received on Wed Jun 20 23:43:13 2007

This is an archived mail posted to the Subclipse Users mailing list.