[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-users] subclipse problems with svn externals

From: Glenn R. Golden <ggolden_at_umich.edu>
Date: 2006-03-22 03:34:42 CET

We have a project (www.sakaiproject.org) that is switching over to
heavy use of svn:externals. We have a root svn area that uses
svn:externals settings to collect a number of Eclipse projects together.

You can check it out with this command:

        svn co https://source.sakaiproject.org/svn/sakai/branches/sakai-2.2

The checkout creates a "sakai-2.2" directory, and in there are the
projects we want to import into Eclipse. Each of these projects has
Eclipse .classpath and .project files checked in.

I am having trouble getting these checked out modules to work with
Subclipse in Eclipse

Using import, or adding each one as a separate project into Eclipse,
I get the following error related to the project's SVN information:

        An internal error occurred during: "Auto-sharing imported subversion
projects".
        java.lang.NullPointerException

A screen shot of the multi-project import is attached.

The projects are in Eclipse work ok for Eclipse, but they do not have
their SVN connection.

Feel free to try this with the above SVN address.

I wonder if I'm doing something wrong, if there's any way to make
this work with this version, or if this is a bug or missing feature
in Subclipse.

Version information:

Mac OS X 10.4.5 (ppc)

Eclipse SDK
Version: 3.1.2
Build id: M20060118-1600

Subclipse 0.9.108

Subversion command-line client, version 1.2.0.

Thanks!

- Glenn

Glenn R. Golden
Software Architect, University Of Michigan
ggolden@umich.edu


Received on Wed Mar 22 03:35:43 2006

This is an archived mail posted to the Subclipse Users mailing list.