[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Incompatible JavaHL library

From: Markus Schönhaber <subclipse_at_schoenhaber.de>
Date: 2005-12-04 02:17:58 CET

Christian Sell wrote:
> I am trying to get my JavaHL install back on track. I am now using the
> subversion 1.2.3 install that comes with SuSE 10. I have the javahl
> libraries in LD_LIBRARY_PATH. When I now try to activate JavaHL in
> subclipse, I get the following messages:
> no libsvnjavahl-1 in java.library.path
> Incompatible JavaHL library loaded. 1.3.x or later required
> can someone explain what is going wrong?

Seems like you have installed Subclipse 0.9.100.
In the first paragraph of his announcement
Mark answers your question: Subclipse 0.9.100 is based upon Subversion 1.3.0
(RC4). So if you want to use the JavaHL client adapter with this Subclipse
build, you need the JavaHL 1.3.0 binaries. And this is what the error message
tells you.

Received on Sun Dec 4 12:17:58 2005

This is an archived mail posted to the Subclipse Users mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.