[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: subclipse (client adapter)

From: CÚdric Chabanois <cchabanois_at_no-log.org>
Date: 2004-12-08 22:46:34 CET

forwarded to users@subclipse.tigris.org mailing list

>On Tuesday 07 December 2004 09:28, you wrote:
>
>
>>We will use javasvn in a near future (which is open-source :
>>http://tmate.org/svn/).
>>I started the integration but I did not put the jar in repository.
>>I did it a few days ago. You should be able to compile svnClientAdapter.
>>However I have not updated build.xml file yet.
>>
>>
>Uh, right, I am sorry, with http://tmate.org I was redirected away.
>
>I ran into the same /usr/lib/libsvnjavahl-1.so problems reported by bug #182.
>Maybe for some security reason or what ever jvm (1.4.2_05-b04 running on
>current gentoo linux) seems to
>ignore any dlls not in the java.library.path:
>
>i appended to the svnClientAdapter's dll patchwork:
> try {
>
> System.load("/usr/lib/libsvnjavahl-1.so");
>
> } catch (UnsatisfiedLinkError e) {
> System.out.println(e);
> System.loadLibrary("svnjavahl");
> }
>
>but the same problem still appears in /usr/lib/svn-javahl/svn-javahl.jar
>
>Using javahl factory
>Exception in thread "main" java.lang.UnsatisfiedLinkError: no svnjavahl in
>java.library.path
> at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1517)
> at java.lang.Runtime.loadLibrary0(Runtime.java:788)
> at java.lang.System.loadLibrary(System.java:834)
> at org.tigris.subversion.javahl.SVNClient.<clinit>(SVNClient.java:48)
> at
>org.tigris.subversion.javahl.SVNClientSynchronized.<init>(SVNClientSynchronized.java:39)
> at
>org.tigris.subversion.svnclientadapter.javahl.JhlClientAdapter.<init>(JhlClientAdapter.java:75)
> at
>org.tigris.subversion.svnclientadapter.javahl.JhlClientAdapterFactory.createSVNClientImpl(JhlClientAdapterFactory.java:33)
> at
>org.tigris.subversion.svnclientadapter.SVNClientAdapterFactory.createSVNClient(SVNClientAdapterFactory.java:60)
> at org.tigris.subversion.svnclientadapter.samples.Sample.run(Sample.java:144)
> at
>org.tigris.subversion.svnclientadapter.samples.Sample.main(Sample.java:177)
>
>SVNClient:
>try
> {
> System.loadLibrary("libsvnjavahl-1");
> }
> catch (UnsatisfiedLinkError e)
> {
> System.loadLibrary("svnjavahl");
> }
>
>that can be IMHO fixed the same way.
>
>If you put -Djava.library.path=/usr/lib into the VM argument field,
>that gives directly for an application a succes
>(but I found no way how to set it for any plugin??):
>
>Using javahl factory
>cat -r HEAD
>http://svn.collab.net/repos/subclipse/trunk/svnClientAdapter/readme.txt
>The beginning of the file is :
>
>svnClientAdapter
>===============
>
>SVNClientAdapter uses javahl Subversion library (http://svn.colla
>
>-----------------------------------------------------------------------------
>
>I imported core and ui (eclipse3 branch), replaced the old
>svnClientAdapter.jar, svn-javahl.jar, etc.
>but for endless problems with the plugin configuration files (that I don't
>fully grasp), I gave up.
>
>It was be great (at least for me, a plugin idiot;-) if you
>can update the eclipse conf. files in the eclipse3-branch
>to bekome some first working state -- i.e. simply
>by importing ui & core & svnClientAdapter into the eclipse.
>Fixing this (minor) dll problems should be a easy job,
>cose everything else seems to be working fine.
>
>Thanks a lot
>
>Martin
>& my 30 JavaKids (still fighting with the old cvs:-)
>
>
>
>
>
>
>
>
>
Received on Thu Dec 9 08:46:34 2004

This is an archived mail posted to the Subclipse Users mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.