[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Subclipse-dev] Switch not working in Subclipse + Juno

From: Mark Phippard <markphip_at_gmail.com>
Date: Tue, 18 Dec 2012 17:40:20 -0500

If the console shows it worked and the command line shows it worked, then it did work. The UI uses a cache that must not have refreshed. Use team > refresh option.

Sent from my iPad

On Dec 18, 2012, at 5:36 PM, David Witherspoon <psynoff_at_yahoo.com> wrote:

> Hi,
>
> In the past I have used the switch feature with great success with the Subclipse plugin with Eclipse.
>
> I recently upgraded my Ubuntu rig to 12.04, installed the new Juno version of Eclipse, plus the latest Subclipse plugin.
>
> Everything has been fine...but the switch feature just isn't working.
>
> I have:
> Subversion Client Adapter 1.8.3
> Subversion JavaHL 1.7.7
> Subversion Revision Graph 1.1.1
> Subversion Team Provider Core 1.8.16
> SVNKit Client Adapter 1.7.5.1
>
> It doesn't matter whether I create the branch from within Eclipse or externally from the command line. When I try project R> Team > Switch to another Tag/Branch/Revision, it acts like it's working. So it displays the command being executed and shows normal output otherwise.
>
> But then project R> Properties > Subversion shows a trunk URL, rather than the branch.
>
> If I then go to the folder holding the project and issue "svn info", it tells me that I'm using the branch.
>
> I've tried deleting the entire project, deleting the branch, and starting over from scratch...same result.
>
> I did try about 4 times with another project, including getting out of Eclipse and back in again...and it finally managed to show it as a branch rather than trunk.
>
> See the attached screen shot showing the issue. Is it a bug?
>
> - David Witherspoon
> <SubclipseSwitchProblem.png>

------------------------------------------------------
http://subclipse.tigris.org/ds/viewMessage.do?dsForumId=1043&dsMessageId=3036954

To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_subclipse.tigris.org].
Received on 2012-12-18 23:47:00 CET

This is an archived mail posted to the Subclipse Dev mailing list.