[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-dev] Availability of Subversion 1.5 JavaHL library on Linux and OSX

From: Mark Phippard <markphip_at_gmail.com>
Date: Wed, 30 Apr 2008 10:50:13 -0400

CollabNet is providing binaries for Subversion 1.5 for Windows, Linux
and OSX. You can download those packages here:

http://merge-tracking.open.collab.net/servlets/ProjectProcess?pageID=3711

Subclipse already includes the JavaHL binaries for Windows, so this
message is really for those of you on Linux or OSX that want to use
the latest Subclipse and need JavaHL to do so. If you install the
above binaries they include JavaHL. You then have two options for
using that JavaHL in Eclipse:

1) Edit your eclipse.ini and add a line like this:

Linux:
-Djava.library.path=/opt/CollabNet_Subversion/lib

OSX:
-Djava.library.path=/opt/subversion-1.5.x/lib

2) CollabNet has provided Eclipse plugins for Linux and OSX that
includes the JavaHL library (still requires you have installed the
binary packages first though). These are available on the same update
sites where we include our merge client that is built on Subclipse.
The update site URL's are:

Eclipse 3.2: http://downloads.open.collab.net/eclipse/merge-client/e3.2
Eclipse 3.3: http://downloads.open.collab.net/eclipse/merge-client/e3.3

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subclipse.tigris.org
For additional commands, e-mail: dev-help_at_subclipse.tigris.org
Received on 2008-04-30 16:50:22 CEST

This is an archived mail posted to the Subclipse Dev mailing list.