[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[Subclipse-dev] Subclipse trunk changes -- and new developer

From: Mark Phippard <markphip_at_gmail.com>
Date: 2007-05-03 22:03:41 CEST

I have merged the svn-1.5 branch into trunk. This means that trunk
now requires Subversion 1.5 (trunk) for JavaHL and SVNKit does not
currently work. I have added Windows binaries for those on Windows.
I have been building from source on OSX and Linux too. I'd suggest
you do the same.

I'd also like to announce and welcome a new developer to our project,
Steve Elsemore. Many of you do not know Steve but he worked with me
at my previous job and wrote a good percentage of the code I committed
to Subclipse over the years. He has joined me at ColllabNet and I
will be able to allocated part of his time to working on Subclipse. I
have asked Steve to take a higher profile role than he used to, such
as participate on this mailing list. I am also going to make Steve a
committer, rather than doing the commits for him as I used to.

I am going to be putting Steve to work on our roadmap, primarily the
svn 1.5 features for the Subclipse 1.4.0 release. When Subversion
gets to the RC-1 stage, I want to start issuing Subclipse 1.3.x
releases for testing.

I have added a couple of 1.5 features already, such as improvements to
the refactoring code.

There are some other changes in trunk.

1) core and ui projects have been renamed in their .project file. I
did not rename the folders in the repository.

2) Several new projects related to svnClientAdapter. You will need these:

org.tigris.subversion.clientadapter
org.tigris.subversion.clientadapter.javahl
org.tigris.subversion.clientadapter.javahl.win32 (if on Windows)

These projects use svn:externals to point back at the svnClientAdapter project.

Basically these turn svnClientAdapter into a plug-in that uses Eclipse
extension points to get the adapter.

3) There is also a project for svnkit. This requires the SVNKit
plug-in be installed from SVNKit.com. This plug-in does not really
work yet as it does not have the new 1.5 features.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subclipse.tigris.org
For additional commands, e-mail: dev-help@subclipse.tigris.org
Received on Thu May 3 22:04:07 2007

This is an archived mail posted to the Subclipse Dev mailing list.