RE: [Subclipse-dev] Verbose commit
On Wed, 2005-06-29 at 08:54 -0400, Mark Phippard wrote:
> > > 2) If not, then we can just change the signature, if we do
> > > then how about
> > > runWithMonitor() as the new method name instead of runDirectly()?
> > I agree.
> We should probably just stick wtih run().
I haven't been following this discussion, but will toss in the comment
that using method names from common interfaces like Runnable can often
come back to bite you. I admit that for Subclipse that might be a bit
far-fetched, but it is a practice I tend to follow. If the containing
class really should implement Runnable, well, that solves that too.
Received on Thu Jun 30 14:30:52 2005
This is an archived mail posted to the Subclipse Dev