[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Dependencies for windows version of javahl dll

From: Brock Janiczak <brockj_eclipse_at_ihug.com.au>
Date: 2004-08-29 13:01:02 CEST

Hi All,

It appears that the 1.1 rc2 version of the javahl libraries for windows
requires the Apache Portable Runtime dlls in order to function
correctly. This was not a requirement for the 1.0 version of the dll
and as such the apr dlls are not shipped with the win32 feature. This
has made the new releases of subclipse unusable for win32 people (like
myself). The workaround is to manually copy the dlls from the
svnClientAdapter project into your windows system root (system32).

The odd thing is that the size of the javahl lib is about the same as
the 1.0 version.

I don't have a copy of visual studio, so i can't re compile the dll.
Can anyone else have a go at removing the dependency on APR?
Perhaps one of the javahl maintainers might be nice enough to create us
a binary :)

Cheers,
    Brock
Received on Sun Aug 29 21:01:02 2004

This is an archived mail posted to the Subclipse Dev mailing list.