[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

repo-preview using wrong revision + copy command gone?

From: Holger Rehn <holger.rehn_at_sql-gmbh.de>
Date: 2004-07-13 09:46:40 CEST

hi,
 
I'm using subclipse 9.10 and just realized that in the SVN perspective the
copy command doesn't work anymore. I can 'copy' something but when I hit
'paste' subclipse tells me 'The chosen operation is not currently
available.' is this an known issue (didn't find it in the issue list)?
and then I have another one - something which I'm seeing since my first
experiments with subclipse 9.0 or whatever it was 6 weeks ago: when I try to
open a file directly from the repository subclipse tries to 'cat' a wrong
revision of that file (and fails) if the containing folder has been moved or
copied around. I suppose it is caused by the fact that subclipse is trying
to get the last-changed revision instead of the head revision and by copying
a folder the files inside are not marked as changed in that revision.
copying a single file always worked because that marks it as changed. since
(until now) there is no possibility to browse a given repository revision in
subclipse there shouldn't be a reason not to always go for the head
revision. if there are plans to make the repo-browser more complete and
allow the user to browse a certain revision this issue wouldn't be a problem
at all since then you just take the revision the browser is set to for all
operations.
 
ciao
momo
 
p.s. thanx for the good work done so far
Received on Tue Jul 13 17:46:40 2004

This is an archived mail posted to the Subclipse Dev mailing list.