[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

subclipse-M6-all-r403 windows errors

From: Geoff Howard <geoff_at_leverageweb.com>
Date: 2004-02-11 02:27:41 CET

Apologies if these sorts of questions are better on the users list -
just let me know...

I just tried out this latest build on windows XP with -vm pointing to
j2sdk1.4.2_02, in a fresh download of M6 using an empty new -data
workspace and it appears to have problems. Trying to connect to
http://svn.collab.net/repos/subclipse/trunk/ it appears to connect and
validate, but when I try to browse the new location, I get a generic
error message with this in .log: (more below stack trace)

!ENTRY org.eclipse.ui 4 4 Feb 10, 2004 17:17:59.861
!MESSAGE Unhandled event loop exception
!ENTRY org.eclipse.ui 4 0 Feb 10, 2004 17:17:59.871
!MESSAGE java.lang.NoClassDefFoundError
!STACK 0
java.lang.NoClassDefFoundError
        at
org.tigris.subversion.svnclientadapter.javahl.JhlClientAdapter.<init>(JhlClientAdapter.java:103)
        at
org.tigris.subversion.svnclientadapter.SVNClientAdapterFactory.createSVNClient(SVNClientAdapterFactory.java:80)
        at
org.tigris.subversion.subclipse.core.SVNProviderPlugin.createSVNClient(SVNProviderPlugin.java:341)
        at
org.tigris.subversion.subclipse.core.repo.SVNRepositoryLocation.getSVNClient(SVNRepositoryLocation.java:229)
        at
org.tigris.subversion.subclipse.core.resources.RemoteFolder.getMembers(RemoteFolder.java:131)
        at
org.tigris.subversion.subclipse.core.resources.RemoteFolder.members(RemoteFolder.java:229)
        at
org.tigris.subversion.subclipse.core.repo.SVNRepositoryLocation.members(SVNRepositoryLocation.java:148)
        at
org.tigris.subversion.subclipse.ui.repository.model.SVNRepositoryRootElement.internalGetChildren(SVNRepositoryRootElement.java:53)
        at
org.tigris.subversion.subclipse.ui.repository.model.SVNModelElement.getChildren(SVNModelElement.java:58)
        at
org.tigris.subversion.subclipse.ui.repository.model.SVNModelElement.getChildren(SVNModelElement.java:80)
        at
org.tigris.subversion.subclipse.ui.repository.model.RemoteContentProvider.getChildren(RemoteContentProvider.java:53)
        at
org.eclipse.jface.viewers.AbstractTreeViewer.getRawChildren(AbstractTreeViewer.java:729)

...

Dont' know if this is helpful, but if I leave the inactive location,
exit eclipse, come back in and try to browse the location, this time I
get the error message:

The ordinal 2411 could not be located in the dynamic link library
LIBEAY32.dll

with this in .log:

!ENTRY org.eclipse.ui 4 4 Feb 10, 2004 20:22:40.994
!MESSAGE Unhandled event loop exception
!ENTRY org.eclipse.ui 4 0 Feb 10, 2004 20:22:41.25
!MESSAGE
D:\eclipse-3M6\eclipse\plugins\org.tigris.subversion.subclipse.core_0.8.6\svnjavahl.dll:
The operating system cannot run %1
!STACK 0
java.lang.UnsatisfiedLinkError:
D:\eclipse-3M6\eclipse\plugins\org.tigris.subversion.subclipse.core_0.8.6\svnjavahl.dll:
The operating system cannot run %1
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1560)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1469)
        at java.lang.Runtime.loadLibrary0(Runtime.java:788)
        at java.lang.System.loadLibrary(System.java:834)
        at org.tigris.subversion.javahl.SVNClient.<clinit>(SVNClient.java:34)
        at
org.tigris.subversion.svnclientadapter.javahl.JhlClientAdapter.<init>(JhlClientAdapter.java:103)
        at
org.tigris.subversion.svnclientadapter.SVNClientAdapterFactory.createSVNClient(SVNClientAdapterFactory.java:80)
        at
org.tigris.subversion.subclipse.core.SVNProviderPlugin.createSVNClient(SVNProviderPlugin.java:341)
        at
org.tigris.subversion.subclipse.core.repo.SVNRepositoryLocation.getSVNClient(SVNRepositoryLocation.java:229)
        at
org.tigris.subversion.subclipse.core.resources.RemoteFolder.getMembers(RemoteFolder.java:131)
        at
org.tigris.subversion.subclipse.core.resources.RemoteFolder.members(RemoteFolder.java:229)
        at
org.tigris.subversion.subclipse.core.repo.SVNRepositoryLocation.members(SVNRepositoryLocation.java:148)
        at
org.tigris.subversion.subclipse.ui.repository.model.SVNRepositoryRootElement.internalGetChildren(SVNRepositoryRootElement.java:53)
        at
org.tigris.subversion.subclipse.ui.repository.model.SVNModelElement.getChildren(SVNModelElement.java:58)
        at
org.tigris.subversion.subclipse.ui.repository.model.SVNModelElement.getChildren(SVNModelElement.java:80)
        at
org.tigris.subversion.subclipse.ui.repository.model.RemoteContentProvider.getChildren(RemoteContentProvider.java:53)
        at
org.eclipse.jface.viewers.AbstractTreeViewer.getRawChildren(AbstractTreeViewer.java:729)

...

Any clues? Has anyone gotten this working on windows?

Geoff
Received on Wed Feb 11 12:27:41 2004

This is an archived mail posted to the Subclipse Dev mailing list.