[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: SVN 1.14 release: please fix your buildbot

From: <bert_at_qqmail.nl>
Date: Wed, 6 May 2020 13:38:05 +0200

This buildbot runs python 2.X (and has for years) and now the tests are
broken. I don't remember seeing changes to the actual Conflict handing code
in Subversion itself, so...
I still think this is related to the changes to the test framework causing
regressions on 2.7.

This buildbot does the testing on Windows with python 2.7... But errors on
this bot are often ignored by *nix developers. (It reported errors for some
weeks because build.conf was broken for Windows... and once that was fixed
this new problem existed so 'nobody' noticed)

-----Oorspronkelijk bericht-----
Van: Yasuhito FUTATSUKI <futatuki_at_poem.co.jp>
Verzonden: woensdag 6 mei 2020 13:19
Aan: dev_at_subversion.apache.org; bert_at_qqmail.nl
Onderwerp: Re: SVN 1.14 release: please fix your buildbot

On 2020/05/06 19:48, bert_at_qqmail.nl wrote:
> The Windows buildbots currently produce actual errors, most likely
> caused by recent changes to the python test framework. (It is
> expecting to see \r, but now sees \n in several text conflicts)

The reason of failures aren't recent changes of the python test framework,
but no one cared of the tests on Windows with Python 3. Please see the
thread "Problems running testsuite on Windows with Python 3" [1].

We are now working to try to fix it.

[1]
https://lists.apache.org/thread.html/r87a33f0046949fe59188e844832297d8a00e67
5c4e59a1ab01005e0e%40%3Cdev.subversion.apache.org%3E

Cheers,

--
Yasuhito FUTATSUKI <futatuki_at_poem.co.jp>/<futatuki_at_yf.bsdclub.org>
Received on 2020-05-06 13:38:20 CEST

This is an archived mail posted to the Subversion Dev mailing list.