[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] svnadmin build-repcache command

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Wed, 1 Apr 2020 12:05:10 +0000

Daniel Shahaf wrote on Wed, 01 Apr 2020 10:26 +0000:
> Stefan Sperling wrote on Wed, 01 Apr 2020 12:18 +0200:
> > On Wed, Apr 01, 2020 at 09:59:41AM +0000, Daniel Shahaf wrote:
> > > Stefan Sperling wrote on Wed, 01 Apr 2020 11:13 +0200:
> > > > https://ci.apache.org/builders/svn-x64-macosx-fsfs-v6/builds/2941/steps/Test%20ra_local%2Bfsfs-v6/logs/faillog
> > > >
> > > > The svnadmin build-repcache test runs into a checksum mismatch.
> > > >
> > > > Any ideas?
> > >
> > > Note the "actual" checksum is the checksum of the empty string.
> > >
> >
> > Oh, interesting point :)
> >
> > I cannot see what's wrong. An empty stream is returned from
> > svn_fs_fs__get_contents() if the passed in rep pointer is NULL,
> > but I don't think that's where the bug is.
> >
> > Perhaps the failing test really read empty rep content for some reason?
> > I'm now running this test in a loop, but I could not reproduce the
> > failure yet.
>
> Are you running your local tests using the same configuration the
> builder uses? (Even without looking up the build script, the builder's
> name suggests it uses FSFS f6, i.e., --server-minor-version.)
>

The failure is 100% reproducible with «./svnadmin_tests.py
--fs-type=fsfs --fsfs-version=6 74» on Linux.

Let's wait to hear from Denis.

> If you haven't already, re-run that builder using subversion-bot to
> check if the bug is reproducible.
>
> The error trace goes through cache.c; SVN_X_DOES_NOT_MARK_THE_SPOT in
> notes/knobs can be used to rule out svn_cache__t as the cause.
Received on 2020-04-01 14:05:18 CEST

This is an archived mail posted to the Subversion Dev mailing list.