[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [offlist] Re: Merging branches/swig-py3 to trunk

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Fri, 8 Nov 2019 09:53:55 +0000

Julian Foad wrote on Fri, Nov 08, 2019 at 08:13:20 +0000:
> If I did my search correctly, there is nothing about Python 3 in any of the
> 1.10 through 1.14 release notes. Haven't we got something to say about
> limited support (for build and test?) in some version before 1.14? All I
> could find was one py3 build fix (r1819444) merged to 1.10.x.

Are you looking for this? —

https://subversion.apache.org/docs/release-notes/1.9#python-2.7

It's interesting to notice that in that paragraph, we dropped support for py2.5
several years after it had gone EOL; and I remember that we added that
paragraph, not as a "planning ahead" thing well ahead of creating the 1.9.x
branch, but as a last-minute addition, shortly before the 1.9.0 final release.
That, and our failure to add support for Python 3 well ahead of py2's EOL, begs
the question of what _other_ dependencies of us are (or will soon be) EOL.

Cheers,

Daniel
Received on 2019-11-08 10:54:02 CET

This is an archived mail posted to the Subversion Dev mailing list.