[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bug in tools/server-side/svnpubsub/svnwcsub.py

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Fri, 25 May 2018 14:51:52 +0000

[moved from users@]

sebb wrote on Fri, 25 May 2018 15:15 +0100:
> On 25 May 2018 at 14:37, Daniel Shahaf <d.s_at_daniel.shahaf.name> wrote:
> > sebb wrote on Fri, 25 May 2018 14:14 +0100:
> >> The following fails because fname is not defined:
> >>
> >> self.read(fname) [1]
> >>
> >> it should be
> >>
> >> self.read(self.fname)
> >
> > Thanks for the report.
> > With that change, the [DEFAULT] section doesn't get emptied by reload().
>
> Seems to me that is a separate issue.
>

Right now, reload() raises NameError whenever called.

Fixing the NameError without making reload() reload the [DEFAULT]
section would make reload() silently broken.

Therefore, I think the [DEFAULT] non-emptying should be fixed at the
same time as fixing the NameError.

> > Would you like to send a patch that fixes that as well (in addition to the NameError)?
>
> I've no idea how to patch that.
> I just know that my proposed fix stops the reload from failing.
>
> > Replies to dev@, please.
>
> Do you want me to raise a JIRA for the NameError?

Only if the invisible hand doesn't produce a patch that fixes both issues... :-)

Daniel

P.S. If there hadn't been the [DEFAULT] issue I'd have just asked you to
     commit your patch, but as explained above, that issue's existence
     means the patch would trade a loud failure mode for a silent one.
Received on 2018-05-25 16:52:45 CEST

This is an archived mail posted to the Subversion Dev mailing list.