[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Minimum version of JDK for Subversion 1.10 (was Re: JDK 10 removal of javah)

From: Stefan Sperling <stsp_at_elego.de>
Date: Fri, 18 May 2018 14:34:32 +0200

On Fri, May 18, 2018 at 08:22:46AM -0400, James McCoy wrote:
> On Fri, May 18, 2018 at 09:46:41AM +0200, Stefan Sperling wrote:
> > Elsewhere in this discussion thread it was suggested to raise the
> > minimum JDK version requirement to Java 1.8.
> > Your statement "please keep backward compatibility with older JDKs"
> > could mean anything between "please leave everything as it is now" to
> > "bumping the minimum requirement to Java 1.8 is absolutely fine with me".
> >
> > This requirement would be introduced for Subversion 1.11.
> > Can you explain which versions of OS X / JDK you expect to support when
> > Subversion 1.11 will be released in probably 2 to 3 years from now?
>
> No one would be able to build the stable release of Subversion with JDK
> 10 for 2 to 3 years?
>
> Supporting both pre-8 and post-8 JDKs wouldn't be trivial. I've been
> working under the assumption that we can bump up to JDK 8 and backport
> that change to 1.10.
>
> If that's not going to be the case, should my current work still go to
> trunk? Then someone can find the time to adapt things to also work with
> pre-8 JDK?

I think you should aim to proceed with your plan as it was.
If anyone has strong objections to this, they should be constructive and
try to provide an alternative solution without pushing an additional
burden on you.
Received on 2018-05-18 14:34:38 CEST

This is an archived mail posted to the Subversion Dev mailing list.