[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: A rational svn shelve/checkpoint CLI

From: Branko Čibej <brane_at_apache.org>
Date: Mon, 8 Jan 2018 15:21:01 +0100

On 08.01.2018 14:31, Julian Foad wrote:
> Towards a more rational shelving-with-checkpoints CLI.
>
>   svn shelf-{save,shelve,unshelve,shelves,log,drop,diff}
>     [SHELF_SPEC...] [PATH...]
>
> SHELF_SPEC:
>
>   --shelf=[SHELF][.VERSION]
>   @[SHELF][.VERSION]
>
>     Specify shelf SHELF (name, 'all', 'newest'), version VERSION
>     (number, date, 'all', 'newest'). Defaults are per command.
>
>   --version=VERSION
>
>     Specify the default version for shelf specs in the command.
>
> Aliases:
>
>   svn save            -> svn shelf-save
>   svn shelve          -> svn shelf-shelve
>   svn unshelve        -> svn shelf-unshelve
>   svn shelves         -> svn shelf-shelves

This naming doesn't make any sense to me. Using a word root in the same
command as both a noun and a verb runs counter to my notions of proper
grammar. It doesn't look right. The following would be better:

    shelf-save, shelf-restore, shelf-list, shelf-log, shelf-drop,
shelf-diff.[*]

Adding a common prefix to existing commands without renaming the
commands doesn't always make sense.

[*] It would be even better without the dash: 'shelf save', 'shelf
restore', and so on; but I realise that would involve either custom
command interpretation or some deep surgery in our command-line parser.

-- Brane
Received on 2018-01-08 15:21:05 CET

This is an archived mail posted to the Subversion Dev mailing list.