[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Meta: Inline replies in gmail are broken in text/plain view (was: Re: Tip of the day: Cheatsheet for common cmdline client operations)

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Thu, 21 Sep 2017 23:24:38 +0000

Johan Corveleyn wrote on Thu, 21 Sep 2017 15:54 +0200:
> Op 20 sep. 2017 17:28 schreef "Pavel Lyalyakin" <
> pavel.lyalyakin_at_visualsvn.com>:
>
> Hello,

The line "Hello" was written by Pavel; Johan's MUA should have preceded
it with a ">" but did not. Consequently, the reply is virtually
unreadable in plain text mode: it makes no distinction between the
quoted text (by Pavel) and the new text (by Johan).

I gather — thanks to some excellent detective work by jcorvel — that
this behaviour is a new (mis)feature of gmail, which kicks in when (1)
composing in HTML mode, (2) while composing a reply, adding some
response text inline (as opposed to top-posting). It affects even
replies to text/plain emails (such as Pavel's post, the grandparent of
this one).

I'm not aware of a workaround, but given that this issue does make
emails considerably harder to read in plain text MUAs --- and affects
multiple posters on multiple lists --- I did feel it merited a post.

And as people always ask in such situations: if somebody has a back
channel to the gmail team, please do use it...

Thanks,

Daniel
Received on 2017-09-22 01:24:43 CEST

This is an archived mail posted to the Subversion Dev mailing list.