[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1705060 - in /subversion/trunk/subversion/libsvn_ra_serf: ra_serf.h serf.c util.c

From: Branko Čibej <brane_at_apache.org>
Date: Thu, 24 Sep 2015 18:57:42 +0200

On 24.09.2015 18:56, Branko Čibej wrote:
> On 24.09.2015 18:41, Ivan Zhakov wrote:
>> On 24 September 2015 at 19:29, Julian Foad <julianfoad_at_btopenworld.com> wrote:
>>> Ivan Zhakov wrote:
>>>> On 24 September 2015 at 18:50, Stefan Sperling <stsp_at_elego.de> wrote:
>>>>> On Thu, Sep 24, 2015 at 05:40:45PM +0300, Ivan Zhakov wrote:
>>>>>> I think we use POOL name if function accepts just one pool, and
>>>>>> SCRATCH_POOL/RESULT_POOL in other case. Is not it?
>>>>>>
>>>>>> I would not mind to rename POOL to RESULT_POOL in this particular
>>>>>> case, but I'm not sure that we should use RESULT_POOL in all other
>>>>>> cases if function accepts one pool.
>>>>> We certainly have functions that take only a scratch_pool.
>>>>> The idea is to identify the purpose of the pool, and not only
>>>>> in the case where there are 2 pools.
>>>> I don't think we may use other places with only scratch_pool argument
>>>> as reason:
>>> Perhaps there was a slight misunderstanding there. When you wrote "I'm
>>> not sure that we should use RESULT_POOL in all other cases if function
>>> accepts one pool", perhaps Stefan thought you meant all other cases
>>> where a function accepts one pool, regardless of the purpose of that
>>> pool, and he wanted to refute that suggestion. (I wondered if you
>>> meant that.) But if you meant all other cases where a function takes
>>> one pool and that pool is used for results, then I'd say yes, we
>>> should rename them ... eventually.
>>>
>>>> we also have many functions that accepts just POOL and use
>>>> it as scratch pool. And we also have many functions that uses it as
>>>> result pool.
>>> Yes, we do have many of those. That was the Old Way. Naming the pools
>>> 'scratch_pool' or 'result_pool' is the New Way. We seem to generally
>>> agree that is better, and sometimes we rename the single 'pool'
>>> argument of old functions to either 'scratch_pool' or 'result_pool'.
>>>
>> Could you please give me link to the thread where we discussed The New
>> Way? Yes, we use result_pool/scratch_pool, but I don't remember
>> discussion about never using just one POOL.
> There hasn't been just "a thread". This discussion started way back when
> the design of WC-NG started. And Julian did not say "always use two
> pools". See above; he says "'sratch_pool' or 'result_pool'" twice, not
> the *or*.

I mean "note the *or*" of course.

-- Brane
Received on 2015-09-24 18:57:46 CEST

This is an archived mail posted to the Subversion Dev mailing list.