[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.9.0 minimal Python version (was: Re: [PATCH] Error out with proper error message when using Python >= 3.0

From: Branko ─îibej <brane_at_wandisco.com>
Date: Thu, 23 Jul 2015 08:52:15 +0200

On 22.07.2015 13:46, Daniel Shahaf wrote:
> [Re-sending with a new subject to draw attention to the 1.9 question.]
>
> Daniel Shahaf wrote on Wed, Jul 22, 2015 at 11:31:31 +0000:
>> Stefan Hett wrote on Mon, Jul 20, 2015 at 16:59:08 +0200:
>>> Please note that while testing I also found 1.7/1.8 not working with
>>> Python 3.4.3 as well. Error (in both cases):
>>> File "gen-make.py", line 271
>>> except getopt.GetoptError, e:
>>> ^
>>> SyntaxError: invalid syntax
>>>
>> The 'except' comma syntax is supported by Python through 2.7 (inclusive)
>> and the 'except' 'as' syntax is supported by Python 2.6 and newer.
>> Currently, trunk advertises support for Python 2.5 and newer (so, in
>> particular, so do the older branches).
>>
>> So, I think we should:
>>
>> - For 1.7/1.8, if we expect people will try to build them with py3,
>> we can apply the patch. (The patch is correct; we must remain
>> compatible with py2.5 on those branches; and we can't easily be
>> compatible with py3 at the same time.)

Ack.

>> - For trunk, I think we should convert to the 'except' 'as' syntax and
>> drop py2.5 support. (Actually, we could drop py2.6 support as well,
>> as py2.6 has been EOL for nearly two years now.)

Ack.

>> - For 1.9, it's a little late to make any changes, but I would consider
>> dropping py2.5 support (and converting to the 'except' 'as' syntax),
>> since for 1.9 py3 support is more important than py2.5 support.
>>
>> Thoughts?

I'd rather not mess with the 1.9 branch at this point ... we're so close
to the release (I hope).

-- Brane

>> References:
>>
>> [py2.5 'except' syntax] https://docs.python.org/2.5/ref/try.html
>> [py2.6 'except' syntax] https://docs.python.org/2.6/reference/compound_stmts.html#the-try-statement
>> [py2.6 EOL] https://www.python.org/dev/peps/pep-0361/
>>
>>> So I guess it might be worthwhile adding some check there too?
>>>
>>> [[[
>>> Detect Python >= 3.0 and error out in gen-make.py (rather than
>>> producing some cryptic error/callstack).
>>>
>>> * gen-make.py
>>> (): Add python version check >= 3.0 and error out.
>>> ]]]
Received on 2015-07-23 08:54:04 CEST

This is an archived mail posted to the Subversion Dev mailing list.