[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Building SVN w/o OpenSSL fails

From: Stefan Hett <stefan_at_egosoft.com>
Date: Mon, 22 Jun 2015 18:40:18 +0200

Hi,

trying to build SVN under Windows (1.9 based - svn-mergeinfo-normalizer
branch) I'm getting the following error.

Please note that I'm not buiding with OpenSSL.

InitializeBuildStatus:
   Touching
"E:\[delete]SVNTest\SVN\src-trunk\Release\obj\subversion\libsvn_ra\libsvn_ra_dll\libsvn_ra_dll.unsuccessfulbuild".
CustomBuild:
   All outputs are up-to-date.
ResourceCompile:
   All outputs are up-to-date.
Link:
   C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\link.exe
/ERRORREPORT:QUEUE
/OUT:"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_ra\libsvn_ra-1.dll"
/NOLOGO /LIBPATH:..\..\..\..\apr\lib
/LIBPATH:"..\..\..\..\apr-util\Release"
/LIBPATH:"..\..\..\..\apr-util\xml\expat\lib\LibR"
/LIBPATH:..\..\..\..\zlib ws2_32.lib rpcrt4.lib mswsock.lib
"libapr-1.lib" "libaprutil-1.lib" ssleay32.lib libeay32.lib secur32.lib
xml.lib zlibstat.lib kernel32.lib user32.lib gdi32.lib winspool.lib
comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib
odbc32.lib odbccp32.lib /NODEFAULTLIB:msvcrtd.lib /DEF:"libsvn_ra.def"
/MANIFEST
/ManifestFile:"E:\[delete]SVNTest\SVN\src-trunk\Release\obj\subversion\libsvn_ra\libsvn_ra_dll\libsvn_ra-1.dll.intermediate.manifest"
/MANIFESTUAC:"level='asInvoker' uiAccess='false'" /DEBUG
/PDB:"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_ra\libsvn_ra-1.pdb"
/LTCG /TLBID:1 /DYNAMICBASE /NXCOMPAT
/IMPLIB:"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_ra\libsvn_ra-1.lib"
/MACHINE:X86 /DLL
"E:\[delete]SVNTest\SVN\src-trunk\Release\obj\subversion\libsvn_ra\libsvn_ra_dll\svn.res"
"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_delta\libsvn_delta-1.lib"
"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_fs\libsvn_fs-1.lib"
"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_repos\libsvn_repos-1.lib"
"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_subr\libsvn_subr-1.lib"
"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_ra_local\libsvn_ra_local-1.lib"
"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_ra_svn\libsvn_ra_svn-1.lib"
"E:\[delete]SVNTest\SVN\src-trunk\Release\subversion\libsvn_ra\svn_ra-1.lib"
LINK : fatal error LNK1181: cannot open input file 'ssleay32.lib'
[E:\[delete]SVNTest\SVN\src-trunk\build\win32\vcnet-vcproj\libsvn_ra_dll.vcxproj]
Done Building Project
"E:\[delete]SVNTest\SVN\src-trunk\build\win32\vcnet-vcproj\libsvn_ra_dll.vcxproj"
(default targets) -- FAILED.

To me this looks like the reference to ssleay32.lib, which according to
the web is part of OpenSSL, should not be added to the library files.

Not being too familiar with the build scripts, can someone point me to
where this library-dependency might (incorrectly?) be added?

Regards,
Stefan
Received on 2015-06-22 18:40:27 CEST

This is an archived mail posted to the Subversion Dev mailing list.