[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Playing with svnmover

From: Bert Huijben <bert_at_qqmail.nl>
Date: Wed, 25 Mar 2015 14:29:21 +0100

Julian, you can just force the windows Ra bot to build a/this/your branch via IRC if you want to verify if it works now. (The Ra bot uses a shared library build, like Johan's environment. The local bot a static library version)

Bert

-----Original Message-----
From: "Julian Foad" <julianfoad_at_gmail.com>
Sent: ‎25-‎3-‎2015 10:00
To: "Johan Corveleyn" <jcorvel_at_gmail.com>
Cc: "Bert Huijben" <bert_at_qqmail.nl>; "dev" <dev_at_subversion.apache.org>
Subject: Re: Playing with svnmover

On 24 March 2015 at 22:50, Johan Corveleyn <jcorvel_at_gmail.com> wrote:
> But now I'm running into a new one:
>
> [[[
> svn_ra-1.lib(ra_loader.obj) : error LNK2019: unresolved external
> symbol _svn_delta__get_debug_editor referenced in function
> _svn_ra_get_commit_editor_ev3
[...]
> ]]]
>
> I suppose the problem is that svn_delta_get_debug_editor is being
> referenced from libsvn_ra/ra_loader.c, but it is only defined in
> debug_editor.h which is private to libsvn_delta. It seems it was
> introduced on the move-tracking-2 branch in r1634591.

Hi Johan. Yes. It's only used to print debug messages. For now, I've
just commented out the calls to it in r1669075.

Sorry again for the difficulties.

If you run into any more undefined symbols, try pinging IRC first, to
see if there is anybody online who can help resolve the issue
immediately. It's a pity you had to wait ten hours for me to respond
on email.

- Julian
Received on 2015-03-25 14:29:52 CET

This is an archived mail posted to the Subversion Dev mailing list.