[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

serf1.3.8. Installation for subversion on solaris 10 sparc

From: kay <kayibm1_at_gmail.com>
Date: Thu, 29 Jan 2015 12:32:00 -0700 (MST)

I am currently having the same issues as previous author (Mohsin). I am
trying to install serf 1.3.8 for subversion on solaris 10 sparc. I
encountered the following error which I understand is a bug on serf1.3.8 on
solaris 10. Please help.

# scons APR=/usr/local/apr/bin/apr-1-config
APU=/usr/local/apr/bin/apu-1-config OPENSSL=/usr
scons: Reading SConscript files ...

scons: warning: EnsureSConsVersion is ignored for development version
File "/doptr/3rdparty/SERF/serf-1.3.8/SConstruct", line 22, in <module>
IndexError: list index out of range:
  File "/doptr/3rdparty/SERF/serf-1.3.8/SConstruct", line 275:
    lib_shared = env.SharedLibrary(LIBNAME, SOURCES + SHARED_SOURCES)
  File "/usr/lib/scons-2.3.3/SCons/Environment.py", line 260:
    return MethodWrapper.__call__(self, target, source, *args, **kw)
  File "/usr/lib/scons-2.3.3/SCons/Environment.py", line 224:
    return self.method(*nargs, **kwargs)
  File "/usr/lib/scons-2.3.3/SCons/Builder.py", line 633:
    return self._execute(env, target, source, OverrideWarner(kw), ekw)
  File "/usr/lib/scons-2.3.3/SCons/Builder.py", line 554:
    tlist, slist = self._create_nodes(env, target, source)
  File "/usr/lib/scons-2.3.3/SCons/Builder.py", line 518:
    target, source = self.emitter(target=tlist, source=slist, env=env)
  File "/usr/lib/scons-2.3.3/SCons/Builder.py", line 344:
    target, source = e(target, source, env)
  File "/usr/lib/scons-2.3.3/SCons/Tool/link.py", line 86:
    target[0].name = version_names[0]

I edited my Sconstruct as suggested in the following patch below and I am
now getting a different

--- SConstruct.old Mon Mar 3 14:34:37 2014
+++ SConstruct Mon Mar 3 14:34:21 2014
@@ -210,7 +210,7 @@
 # Unfortunately we can't set the .dylib compatibility_version option
separately
 # from current_version, so don't use the PATCH level to avoid that build
and
 # runtime patch levels have to be identical.
-env['SHLIBVERSION'] = '%d.%d.%d' % (MAJOR, MINOR, 0)
+#env['SHLIBVERSION'] = '%d.%d.%d' % (MAJOR, MINOR, 0)
  
 LIBNAME = 'libserf-%d' % (MAJOR,)
 if sys.platform != 'win32':
@@ -248,6 +248,7 @@
  
   if sys.platform == 'sunos5':
     env.Append(LIBS='m')
+ env['PLATFORM'] = 'posix'
 else:
   # Warning level 4, no unused argument warnings
   env.Append(CCFLAGS=['/W4', '/wd4100'])
  

Below is the error the error that I am getting after editing the Sconstruct
file:

# scons
scons: Reading SConscript files ...

scons: warning: EnsureSConsVersion is ignored for development version
File "/doptr/3rdparty/SERF/serf-1.3.8/SConstruct", line 22, in <module>
scons: done reading SConscript files.

scons: warning: Support for pre-2.7.0 Python version (2.6.4) is deprecated.
    If this will cause hardship, contact scons-dev_at_scons.org
File "/usr/bin/scons", line 199, in <module>
scons: Building targets ...
cc -o context.o -c -std=c89 -g -O2 -DNDEBUG -DSOLARIS2=10
-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -D_LARGEFILE64_SOURCE -I.
-I/usr/local/apr/include/ apr-1
-I/usr/include context.c
sh: cc: not found
scons: *** [context.o] Error 1
scons: building terminated because of errors.

--
View this message in context: http://subversion.1072662.n5.nabble.com/serf1-3-8-Installation-for-subversion-on-solaris-10-sparc-tp191738.html
Sent from the Subversion Dev mailing list archive at Nabble.com.
Received on 2015-01-29 20:32:59 CET

This is an archived mail posted to the Subversion Dev mailing list.