[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

1.7.19 and 1.8.11 [was: svn commit: r1645547 - in /subversion/branches: 1.7.x/STATUS 1.8.x/STATUS]

From: Branko Čibej <brane_at_wandisco.com>
Date: Mon, 15 Dec 2014 03:11:28 +0100

As you've all seen, I voted against releasing 1.7.19 and 1.8.11, because
the DAV tests don't work with HTTPd 2.4+, which is the system default on
the latest version of OSX. I'd be surprised if OSX is the exception; it
seems to depend not just on the HTTPd version but also on the configured
MPM.

I found that we've had the fix on trunk in davautocheck.sh for over a
year, and have proposed to backport it to 1.7.x and 1.8.x; it's a clean
merge.

I therefore propose that we scratch the 1.7.19 and 1.8.11 releases,
approve the backport and roll 1.7.20 and 1.8.12 with the fix included.

-- Brane

On 15.12.2014 03:05, brane_at_apache.org wrote:
> Author: brane
> Date: Mon Dec 15 02:05:20 2014
> New Revision: 1645547
>
> URL: http://svn.apache.org/r1645547
> Log:
> * STATUS: Propose fix for "make davautocheck" with HTTPd 2.4+.
>
> Modified:
> subversion/branches/1.7.x/STATUS
> subversion/branches/1.8.x/STATUS
>
> Modified: subversion/branches/1.7.x/STATUS
> URL: http://svn.apache.org/viewvc/subversion/branches/1.7.x/STATUS?rev=1645547&r1=1645546&r2=1645547&view=diff
> ==============================================================================
> --- subversion/branches/1.7.x/STATUS (original)
> +++ subversion/branches/1.7.x/STATUS Mon Dec 15 02:05:20 2014
> @@ -73,6 +73,17 @@ Candidate changes:
> Votes:
> +1: philip
>
> + * r1544302, r1544303
> + Add HTTPd lock file configuration for testing against HTTPd 2.4+.
> + Justification:
> + Without this change, the davautocheck tests do not work on some
> + systems where HTTPd 2.4+ is the default; OSX 10.10 is one such case.
> + Notes:
> + As far as I'm concerned, this blocks 1.7.19 and 1.8.11 since the
> + tests won't run on a current version of a supported OS.
> + Votes:
> + +1: brane
> +
> Veto-blocked changes:
> =====================
>
>
> Modified: subversion/branches/1.8.x/STATUS
> URL: http://svn.apache.org/viewvc/subversion/branches/1.8.x/STATUS?rev=1645547&r1=1645546&r2=1645547&view=diff
> ==============================================================================
> --- subversion/branches/1.8.x/STATUS (original)
> +++ subversion/branches/1.8.x/STATUS Mon Dec 15 02:05:20 2014
> @@ -111,6 +111,17 @@ Candidate changes:
> Votes:
> +1: philip
>
> + * r1544302, r1544303
> + Add HTTPd lock file configuration for testing against HTTPd 2.4+.
> + Justification:
> + Without this change, the davautocheck tests do not work on some
> + systems where HTTPd 2.4+ is the default; OSX 10.10 is one such case.
> + Notes:
> + As far as I'm concerned, this blocks 1.7.19 and 1.8.11 since the
> + tests won't run on a current version of a supported OS.
> + Votes:
> + +1: brane
> +
> Veto-blocked changes:
> =====================
>
>
>
Received on 2014-12-15 03:12:03 CET

This is an archived mail posted to the Subversion Dev mailing list.