[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: GNOME keyring in Subclipse bug

From: Mark Phippard <markphip_at_gmail.com>
Date: Thu, 20 Nov 2014 11:38:10 -0500

On Thu, Nov 20, 2014 at 10:22 AM, Mark Phippard <markphip_at_gmail.com> wrote:

> On Thu, Nov 20, 2014 at 10:05 AM, Philip Martin <
> philip.martin_at_wandisco.com> wrote:
>
>> Mark Phippard <markphip_at_gmail.com> writes:
>>
>> > I might be able to try this as I would like to see it get backported.
>>
>> It merges cleanly into 1.8 if you want to build 1.8 rather than trunk.
>>
>>
> I will get the current 1.8.x branch working first so I can confirm the
> crash scenario
> <http://markphip.blogspot.com/>
>

I am stuck here at the moment. I build the current 1.8.x branch and I am
setting up my Eclipse dev environment to use JavaHL from that build. I
confirmed this is the case. I also modified Subclipse so that it would not
warn about gnome-keyring and just let me use it. Currently, I am not able
to make it crash. I can see that keyring is being used. I even manually
locked the keyring and Eclipse prompted to unlock it.

So I need to come up with a crash recipe first.

I recall we sort of had these problems in the past. When the keyring code
landed in a 1.5.x branch it was all working and sometime in the path to
officially being included in 1.6 it stopped. I remember sometimes it was
hard to make it crash reliably.

I will keep playing with it, as I would ideally like to see that the patch
fixes something.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
Received on 2014-11-20 17:39:23 CET

This is an archived mail posted to the Subversion Dev mailing list.