[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: I'm getting 'make check' test failures with 1.7.14 & 1.7.16 releases ...

From: Andreas Stieger <andreas.stieger_at_gmx.de>
Date: Mon, 10 Mar 2014 07:50:28 +0000

Hi,

On 07/03/14 18:51, Alan Nexus wrote:
> Is anyone else getting them?

No. You have not told mentioned what the failures are. See
http://www.catb.org/esr/faqs/smart-questions.html

> Does anyone care that they work?

Yes. The full test suite is run successfully many times by project
contributors, downstream packagers and vendors as well as members of the
public. In fact, every release requires verification of release
artifacts and tests by several people on multiple platforms. You may be
running the tests incorrectly, or miss some required configuration. Some
pointers:
https://subversion.apache.org/docs/community-guide/building.html
https://svn.apache.org/repos/asf/subversion/trunk/subversion/tests/README
https://svn.apache.org/repos/asf/subversion/trunk/subversion/tests/cmdline/README

Your question on getting the test suite to work may be better suited for
the users@ list. https://subversion.apache.org/mailing-lists.html
If after getting a test suite to work in general you have specific test
failures that can be attributed to a concrete issue, please report back
with the source revision built, your configuration options, the build
commands used, the specific output and the contents of fails.log.

Have fun,
Andreas
Received on 2014-03-10 08:51:08 CET

This is an archived mail posted to the Subversion Dev mailing list.