[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1572105 - in /subversion/trunk/subversion: svn/auth-cmd.c svn/cl.h svn/svn.c tests/cmdline/getopt_tests_data/svn--help_stdout tests/cmdline/getopt_tests_data/svn_help_stdout

From: Stefan Sperling <stsp_at_elego.de>
Date: Thu, 27 Feb 2014 13:43:18 +0100

On Thu, Feb 27, 2014 at 04:29:36PM +0400, Ivan Zhakov wrote:
> I'm not native English speaker, but for me 'authentication' is the
> process, while this subcommand is about managing objects
> (credentials).

Yes, I see your point.

But do you want to rename just the subcommand?
The API used internally by 'svn auth' is also using the term 'auth',
svn_config_walk_auth_data(). The directory which stores the data this
subcommand works with is also called 'auth', ~/.subversion/auth.
Renaming just the subcommand would create inconsistencies here.

Is having 'svn creds' very important to you? How about a subcommand alias?
Received on 2014-02-27 13:43:55 CET

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.