[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

svnrdump: libsvn_subr-1.so.0: undefined symbol: apr_atomic_xchgptr

From: adam <adam83b_at_gmail.com>
Date: Thu, 3 Oct 2013 00:55:59 +0200

root_at_sv1 [/root/naox/subversion-1.7.13/]# ./configure
--prefix=/usr/share/subversion-1.7.13
'--with-apxs=/usr/httpd-2.4.4/bin/apxs'
--with-apr=/usr/httpd-2.4.4/bin --with-apr-util=/usr/httpd-2.4.4/bin
&& make

root_at_sv1 [/root/naox/subversion-1.7.13/subversion/svnrdump]# ./svnrdump
/root/naox/subversion-1.7.13/subversion/svnrdump/.libs/lt-svnrdump:
symbol lookup error:
/root/naox/subversion-1.7.13/subversion/libsvn_subr/.libs/libsvn_subr-1.so.0:
undefined symbol: apr_atomic_xchgptr

root_at_sv1 [/root/naox/subversion-1.7.13/subversion/svnrdump]# ldd
/root/naox/subversion-1.7.13/subversion/libsvn_subr/.libs/libsvn_subr-1.so.0
        linux-vdso.so.1 => (0x00007fff037ff000)
        libaprutil-1.so.0 => /usr/httpd-2.4.4/lib/libaprutil-1.so.0
(0x00007f4741ec2000)
        libapr-1.so.0 => /usr/httpd-2.4.4/lib/libapr-1.so.0 (0x00007f4741c93000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f4741a77000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f474183f000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x00007f474161c000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00007f4741408000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f4741204000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f4740fe8000)
        libmagic.so.1 => /usr/lib64/libmagic.so.1 (0x00007f4740dd9000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f4740a81000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f47423cb000)

Seems to be linked fine. Is it a bug in svn?
Everything else (svn, svnadmin, svnlook, svnserver) is working fine,
except for svnrdump
Received on 2013-10-03 11:52:52 CEST

This is an archived mail posted to the Subversion Dev mailing list.