[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] fix exception of gen-make.py using --with-libintl [Re: svn commit: r1504501 - in /subversion/trunk: build.conf build/generator/gen_win.py build/generator/gen_win_dependencies.py gen-make.py win-tests.py]

From: Masaru Tsuchiyama <m.tmatma_at_gmail.com>
Date: Tue, 06 Aug 2013 22:36:17 +0900

Hi.

Does anybody comment my patch?

(2013/07/31 21:53), Masaru Tsuchiyama wrote:
> Hi.
>
> Running gen-make.py with --with-libintl option raises AttributeError exception
> when using svn-win32-libintl.zip
> at http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=2627&expandFolde
> r=2627&folderID=260
>
> _find_libintl in SVNCommonLibrary assumes libintl.h has the defininiton of
> LIBINTL_VERSION. But libintl.h in svn-win32-libintl.zip doesn't have.
>
> I attach a patch to fix it by skipping the version check
> if LIBINTL_VERSION can't be found.
>
> [[[[
> Fix exception when running gen-make.py with --with-libintl option
>
> * build/generator/gen_win_dependencies.py
> (_find_libintl) : skip version check for libintl.h if LIBINTL_VERSION can't be found
> ]]]
>
> This is the stack trace.
>
>> Use '--with-berkeley-db' to configure BDB location.
>> Traceback (most recent call last):
>> File "D:\svnwork\subversion\32bit\exception\gen-make.py", line 330, in <module>
>> main(conf, gentype, skip_depends=skip, other_options=rest.list)
>> File "D:\svnwork\subversion\32bit\exception\gen-make.py", line 60, in main
>> generator = gen_module.Generator(fname, verfname, other_options)
>> File "build\generator\gen_vcnet_vcproj.py", line 36, in __init__
>> 'vcnet-vcproj')
>> File "build\generator\gen_win.py", line 83, in __init__
>> self.find_libraries(True)
>> File "build\generator\gen_win_dependencies.py", line 287, in find_libraries
>> self._find_libintl(show_warnings)
>> File "build\generator\gen_win_dependencies.py", line 1185, in _find_libintl
>> ver = int(match.group(1), 0)
>> AttributeError: 'NoneType' object has no attribute 'group'
>

-- 
Masaru Tsuchiyama <m.tmatma_at_gmail.com>
Received on 2013-08-06 15:36:49 CEST

This is an archived mail posted to the Subversion Dev mailing list.