[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r1498394 - in /subversion/branches/verify-keep-going/subversion: libsvn_repos/dump.c svnadmin/svnadmin.c

From: Daniel Shahaf <danielsh_at_elego.de>
Date: Mon, 1 Jul 2013 15:05:52 +0300

prabhugs_at_apache.org wrote on Mon, Jul 01, 2013 at 12:01:38 -0000:
> /* Show the summary. */
> - if (notify_func && keep_going)
> + if (notify_func && keep_going && found_corruption)
> {
> notify_verification_summary(err, notify_func, notify_baton, iterpool);

Thanks.

> +++ subversion/branches/verify-keep-going/subversion/svnadmin/svnadmin.c Mon Jul 1 12:01:38 2013
> @@ -850,13 +850,16 @@ repos_notify_handler(void *baton,
> case svn_repos_notify_failure_summary:
> if (notify->revision != SVN_INVALID_REVNUM)
> cmdline_stream_printf(feedback_stream, scratch_pool,
> - _("r%ld: %s\n"),
> - notify->revision, notify->err->message);
> + _("\nRevision %ld \n"),
> + notify->revision);
> + if (notify->err)
> + svn_handle_error2(notify->err, stderr, FALSE /* non-fatal */,
> + "svnadmin: ");

How about using "svnadmin: r%ld: " as the prefix, for clarity?

Daniel
Received on 2013-07-01 14:06:29 CEST

This is an archived mail posted to the Subversion Dev mailing list.