[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Commit error using 1.8.0 final

From: Paul Burba <ptburba_at_gmail.com>
Date: Tue, 18 Jun 2013 10:16:29 -0400

On Tue, Jun 18, 2013 at 9:20 AM, Mark Phippard <markphip_at_gmail.com> wrote:
> On Mon, Jun 17, 2013 at 4:00 PM, Lieven Govaerts <svnlgo_at_mobsol.be> wrote:
>> On Mon, Jun 17, 2013 at 9:22 PM, Mark Phippard <markphip_at_gmail.com> wrote:
>>> I updated my Windows laptop to 1.8.0 final. I am trying to commit a
>>> change for Subclipse to tigris.org and it is failing. The error
>>> message is not that helpful. Any ideas how to get better error
>>> information?
>>
>> There might be a higher level option, but in serf you can enable lots
>> of debug logging, at compile time in serf_private.h.
>> SSL_VERBOSE gives huge amount of log lines but is probably what you
>> need here, other interesting flags are SOCK_VERBOSE and CONN_VERBOSE.
>
> I turned on everything and ran command again. Attaching the output.
>
> I also created a test project on tigris. So far, all commits are
> working for that project -- which I guess is good news. Maybe some
> odd scenario I am running into.

Getting somewhere on this...

I tried to commit some text changes and added binaries to a tigris
sandbox and saw no problems:

C:\SVN\tigris-sandbox>svn ci -m "Text changes and added binaries"
Sending DIR-A\DIR-B\authors.xml
Sending DIR-A\DIR-B\build.xml
Adding (bin) DIR-A\DIR-C\authz_tests.pyc
Adding (bin) DIR-A\DIR-C\autoprop_tests.pyc
Adding (bin) DIR-A\DIR-C\basic_tests.pyc
Adding (bin) DIR-A\DIR-C\blame_tests.pyc
Adding (bin) DIR-A\DIR-C\javaws.jar
Adding (bin) DIR-A\DIR-C\jce.jar
Adding (bin) DIR-A\DIR-C\jfr.jar
Adding (bin) DIR-A\DIR-C\svn.exe
Transmitting file data ..........
Committed revision 5.

That was with a debug build. Then I tried a release build and sure
enough, I see the problem Mark reported:

C:\SVN\tigris-sandbox>svn ci -m "1.8 Release build (yeah, this is a
shot in the dark) text mods and added binaries"
Adding (bin) DIR-A\DIR-C\__init__ - Copy.pyc
Adding (bin) DIR-A\DIR-C\authz_tests - Copy.pyc
Adding (bin) DIR-A\DIR-C\autoprop_tests - Copy.pyc
Adding (bin) DIR-A\DIR-C\basic_tests - Copy.pyc
Adding (bin) DIR-A\DIR-C\blame_tests - Copy.pyc
Adding (bin) DIR-A\DIR-C\ezt - Copy.pyc
Adding (bin) DIR-A\DIR-C\gen_base - Copy.pyc
Adding (bin) DIR-A\DIR-C\gen_vcnet_vcproj - Copy.pyc
Adding (bin) DIR-A\DIR-C\gen_win - Copy.pyc
Adding (bin) DIR-A\DIR-C\javaws - Copy.jar
Adding (bin) DIR-A\DIR-C\jce - Copy.jar
Adding (bin) DIR-A\DIR-C\jfr - Copy.jar
Adding (bin) DIR-A\DIR-C\svn - Copy.exe
Sending foo.txt
svn: E120106: Commit failed (details follow):
svn: E120106: Error running context: The server sent a truncated HTTP
response body.

Can anyone confirm they are seeing similar differences between release
and debug builds?

--
Paul T. Burba
CollabNet, Inc. -- www.collab.net -- Enterprise Cloud Development
Skype: ptburba
> I am just committing some new files though, so not sure what I am
> doing that would be "weird".
>
> --
> Thanks
>
> Mark Phippard
> http://markphip.blogspot.com/
Received on 2013-06-18 16:17:01 CEST

This is an archived mail posted to the Subversion Dev mailing list.