[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.6.20 up for testing/signing

From: Philip Herron <philip.herron_at_wandisco.com>
Date: Thu, 03 Jan 2013 00:43:53 +0000

On 03/01/13 00:30, Ben Reser wrote:
> This is somewhat offtopic for the release.
> On Wed, Jan 2, 2013 at 3:26 PM, Philip Herron
> <philip.herron_at_wandisco.com> wrote:
>> Debian 5 wouldn't build because needing libserf >= 0.3.0 i could try and
>> remove libserf from the build but tempted to see this as a push to stop
>> support for debian 5. Since i bet later releases of 1.7 will want this also.
> For newer releases I think we've bumped the required version of
> libserf even more than that. The older versions have known bugs. So
> if it's a choice of building your own libserf or using whatever comes
> with the OS, you're probably better off building your own.
> As philipm already pointed out Serf doesn't build unless you
> specifically ask for it with 1.6/1.7. I changed that a while back in
> trunk, so that won't be an issue for 1.8 where Serf is the only HTTP
> library we support.
For the libserf thing on debian 5 i get

error: #error Please update your version of serf to at least 0.3.0.

I think overall i don't think packaging my own libserf as well is a good
idea on lenny old-stable. And packing without libserf seems like not
enough to gain when i will probably get this error now in future
releases so seems like a good idea to shoot debian 5 support now instead
of trying to maintain it with our own packaged dependencies. Since it
will mean a lot of messing with debian rules and control and install
files just for not enough to gain.
Received on 2013-01-03 01:44:29 CET

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.