Combine and rename WC APIs that check WC root and switched
From: Julian Foad <julianfoad_at_btopenworld.com>
Date: Tue, 4 Dec 2012 21:59:59 +0000 (GMT)
These six APIs all overlap in functionality:
1) svn_wc_check_root(*is_wcroot,*is_switched,*kind,...)
2) svn_wc__check_wc_root(*wc_root,*kind,*switched,...)
3) svn_wc__db_is_switched(*is_wcroot,*is_switched,*kind,...)
4) svn_wc_is_wc_root2(*wc_root,...)
5) svn_wc__strictly_is_wc_root(*wc_root,...)
6) svn_wc__db_is_wcroot(*is_root,...)
The first three are functionally identical AFAICT. The duplication adds noise to the WC internal API as a whole. The first to go is svn_wc__check_wc_root() ... gone, r1417181+r1417184.
Now, (1) is a simple wrapper around (3) and (5) is a simple wrapper around (6). Such pairs should have matching names. (1) is public so can't change, so I'll rename (3) to match it:
(3) -> 'svn_wc__db_check_root'
and (5) is named 'strictly' to distinguish it from (4), so I'll leave it alone and rename (6) to match it:
(6) -> 'svn_wc__db_strictly_is_wc_root'.
That should help reduce the obfuscation a tiny bit.
- Julian
-- Certified & Supported Apache Subversion Downloads: http://www.wandisco.com/subversion/downloadReceived on 2012-12-04 23:00:37 CET |
This is an archived mail posted to the Subversion Dev mailing list.
This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.