[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Build from source continues to be broken

From: Ben Reser <ben_at_reser.org>
Date: Wed, 21 Nov 2012 12:30:43 -0800

On Wed, Nov 21, 2012 at 11:15 AM, Eric S. Raymond <esr_at_thyrsus.com> wrote:
> Yes, the build ran to completion this time. Now I can do the
> interesting work, which I've been quiet about because I don't want to
> make any promises I can't keep.

Look forward to seeing whatever you're up to.

> Actually I was trying very hard not to make any decisions at all, just
> follow the least-effort path laid out by the instructions. My error
> seems to have been running autogen.sh without reading INSTALL and
> get-deps.sh first. Perhaps autogen.sh should suggest this?

That doesn't seem unreasonable to me.

> Alas, no. I couldn't use the sqlite binary on my system because it's
> too old - 3.7.9.

Ahh yeah, I suppose sqlite is the one exception. I do usually use the
amalgamation for that.

> I understand this full well, which is why I think deprecating the
> in-tree build is probably a mistake. Keeping one set of source
> dependencies properly tracked is a lot easier than managing
> what is in effect a quirk database for an unbounded number
> of distro and packaging combinations.

As I mentioned before though, the in-tree dependencies are probably
not ideal for most people.

I think our final fix here is going to be to direct people to
get-deps.sh though.
Received on 2012-11-21 21:31:21 CET

This is an archived mail posted to the Subversion Dev mailing list.